CentOS 8.2 Linux系统的错误:GPG 检查失败

subtitle 准妈妈 10-21 12:19

CentOS 8.2 Linux系统中的错误:GPG 检查失败

今天安装CentOS8.2 Linux操作系统,设置完网络,ping百度和网易等网站都能ping通,但是在yum安装时提示错误,提示GPG检查失败。yum install 错误提示如下:

打开网易新闻 查看更多图片

仓库 "CentOS-8 - AppStream" 的 GPG 公钥已安装,但是不适用于此软件包。请检查仓库的公钥 URL 是否配置正确。. 失败的软件包是:wget-1.19.5-8.el8_1.1.x86_64

GPG密钥配置为:file:///etc/pki/rpm-gpg/RPM-GPG-KEY-centosofficial

下载的软件包保存在缓存中,直到下次成功执行事务。

您可以通过执行 'yum clean packages' 删除软件包缓存。

错误:GPG 检查失败

解决办法:

修改yum的配置文件:/etc/yum.conf

vi /etc/yum.conf

完成配置文件的修改后,再命令行中执行更新RPM-GPG-KEY-centosofficial

rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-centosofficial

更新完成后把yum.conf配置文件中的gpgcheck修改回1。

然后执行我们需要执行的安装命令yum install wget,安装正常。

特别声明:本文为网易自媒体平台“网易号”作者上传并发布,仅代表该作者观点。网易仅提供信息发布平台。
Notice: The content above (including the pictures and videos if any) is uploaded and posted by a user of NetEase Hao, which is a social media platform and only provides information storage services.
打开网易新闻,阅读体验更佳
大家都在看